Community

Table not powering ...
 

Table not powering on...  

  RSS

(@kammanbr)
Contributor
Joined: 5 months ago
Posts: 3
September 28, 2020 10:17 am  

I received my mini about a week ago and from the get go I was having trouble powering it on. Seems like it only powered on maybe half of the time. Now I cannot get it to power on at all, nothing happens after plugging it in. Power adapter seems to be working as I am getting the blue light, however there is no light under the table and no ball movement. I have checked the connections underneath and have tried multiple outlets with no success. Has anyone else experienced issues with this?

I am super disappointed considering how new the table is, I am convinced it is defective. There doesn't seem to be any additional troubleshooting I can do. Please help me!


Quote
(@bruce)
Admin
Joined: 3 years ago
Posts: 374
September 29, 2020 6:21 am  

Very sorry to hear - but please know that we will make it right. The best place for troubleshooting and/or setting up a replacement, is on our support desk. Our support staff is very diligent, and will get things fixed quickly: https://sisyphus-industries.zendesk.com/hc/en-us/requests/new

Bruce

This post was modified 4 months ago by Bruce

ReplyQuote
(@pvildaver)
Contributor
Joined: 4 months ago
Posts: 1
October 22, 2020 7:26 pm  

@kammanbr - have you received any additional guidance aside from getting a replacement mini? having the same issue and very upsetting as it is also a new purchase (which has recently been discontinued). 


ReplyQuote
(@bruce)
Admin
Joined: 3 years ago
Posts: 374
October 23, 2020 7:47 am  
@pvildaver - Don't worry about it being "discontinued" - that only concerns the outer "furniture" and not the internal mechanism (which remains the same for all LE Minis). As above, sorry your Sisyphus isn't working properly - it's possible a connector was loosened by vibration during shipping. As above - please contact our support team, who will get things working ASAP.
This post was modified 3 months ago 2 times by Bruce

ReplyQuote
(@kammanbr)
Contributor
Joined: 5 months ago
Posts: 3
December 14, 2020 3:07 pm  

Bruce,

I am having issues again with the replacement mini base I was sent to correct the original issue. It has been working for the past several weeks but now has decided to stop working. I am getting power to the unit but nothing happens, the table does no recalibrate and there is no lights or ball movement. However, there are lights on underneath the table indicating that it is receiving power. Please help!

 

Brad


ReplyQuote
(@kammanbr)
Contributor
Joined: 5 months ago
Posts: 3
December 14, 2020 3:10 pm  

@pvildaver - I was sent a replacement base and that fixed the issue. I think my original unit was defective. I am having issues again though, this time I am getting power to the unit but nothing is happening. Super frustrating considering how expensive these things are! They do not seem very reliable, I can't even display it anymore was it just looks like a $800 box of sand. 


ReplyQuote
(@bruce)
Admin
Joined: 3 years ago
Posts: 374
December 15, 2020 9:44 am  

As before - sorry for the problems you're having and the frustration it causes. But also, as before, the place to troubleshoot and fix issues with your Mini is on our support desk - please contact them for the quickest resolution of the problem: https://sisyphus-industries.zendesk.com/hc/en-us/requests/new


ReplyQuote
Share:

We take your privacy seriously and will only use your personal information to provide you with the products and services you request from us. Please see our privacy policy for more details.

  
Working

Please Login or Register