Community

New user, issues with uploading  

  RSS

(@pawliger)
Contributor
Joined: 2 years ago
Posts: 12
December 1, 2018 6:53 pm  

Just received the table today - the white glove delivery was impressive and went well.

I've got the table going and of course tried to upload some of the great tracks from other users. I am sometimes able to upload a few tracks, but then subsequent upload attempts usually do nothing from the Upload Track screen. Sometimes I get timeout errors, but usually nothing. Anything I can do to supply diagnostics or otherwise help debug? Thanks.


Quote
(@bruce)
Admin
Joined: 2 years ago
Posts: 213
December 2, 2018 9:22 am  

The problems with uploading are known to us, and we're working on them. For now, I suggest doing one file at a time. Make sure your scroll down the web GUI screen and hit the "Save" button (which isn't always visible unless you scroll). You don't necessarily have to wait for the thumbnail image to be created before saving - but if you see the image, it definitely should work (depending on the complexity of the image, it may get done later as it is computed in "background").

Glad to hear your table arrived and delivery was smooth!


ReplyQuote
(@pawliger)
Contributor
Joined: 2 years ago
Posts: 12
December 2, 2018 12:21 pm  

Thanks for the reply. I'll try one file at a time.

Is the preview generator available as a standalone app or webpage? It would be good to know how the drawing will be rendered and would be faster for initial drafts to get a general idea.


ReplyQuote
(@bruce)
Admin
Joined: 2 years ago
Posts: 213
December 2, 2018 4:02 pm  

At this point it just runs in the app. But several of our community tracks have corresponding jpg or png files in the same location you find the thr file. Please bear with this - it should get considerably better soon.


ReplyQuote
(@bikertat77)
Contributor
Joined: 1 year ago
Posts: 7
February 6, 2019 3:18 pm  

Hi, I love the new table, but cannot get new tracks to upload. I finally was able to upload one track but ever since then I cannot download any other tracks. For example, I downloaded the thrones "winter is coming" and it downloaded fine. I went back an hour later and tried to download the pumpkin, turkey, valentines day tracks (all one at a time) and all that happens is the black dots circle around and around then an error message that reads "could not make request" and once I click "okay", the old track of thrones and "winter is coming" pops back up. I have deleted that track, but still cannot download anything from the community tracks.....help???


ReplyQuote
(@heropup)
Contributor
Joined: 2 years ago
Posts: 16
February 6, 2019 6:18 pm  

I created a program that takes an arbitrary .thr and outputs a plot that simulates the drawn track; it can do it in both the forward and reverse directions (if they are different).  The only problem is that it's written in the Wolfram language so it must be run in Mathematica.  If there is interest, I can run the program on all of the .thr files in the Dropbox.


ReplyQuote
(@dithermaster)
Contributor
Joined: 2 years ago
Posts: 53
February 7, 2019 12:54 pm  

Other users who have experienced this didn't download the .thr files correctly (Dropbox doesn't help, the UI isn't great). Please open the .thr files with a text editor (Notepad on Windows, TextEdge on macOS) and verify that it is a bunch of lines with two numbers on each line. If it's not that, please delete and try downloading again until they are.


ReplyQuote
(@bruce)
Admin
Joined: 2 years ago
Posts: 213
February 7, 2019 5:42 pm  

@dithermaster - Thanks for jumping in! Hopefully this will help, but if not - we are aware that there's a lot of improvement to be done with track downloading. A major push is coming in that direction...


ReplyQuote
(@bikertat77)
Contributor
Joined: 1 year ago
Posts: 7
February 7, 2019 7:42 pm  

I don't know. It is frustrating because I have tried multiple ways of downloading tracks and nothing is working. Would enjoy more tracks than those that come with the table, but downloads keep showing same error no matter how I do it. Not to mention the the night mode doesn't work either. Unless it is just me, nice table but the app and downloads don't work.


ReplyQuote
(@dithermaster)
Contributor
Joined: 2 years ago
Posts: 53
February 9, 2019 11:30 am  

You didn't mention what the tracks looked like when you viewed them with a text editor. Knowing that would help diagnose whether this is a download (to your computer) problem or an upload (to table) problem. When the app and web interface are not perfect, they are working reasonably well for other people, including myself.


ReplyQuote
(@bikertat77)
Contributor
Joined: 1 year ago
Posts: 7
February 9, 2019 11:52 am  

I wish I could show how I'm downloading. I feel I am downloading per directions. Bear with me because I am not tech savvy at all. I type in the tables IP address with the :3001 behind it. Opens up a new page where it says my table is up to date.  I click on settings, advance, upload files. At this point I choose the file to download "thr" file. I click download and the black dots spin around and around. The first time I did this, the track did download. Ever since then, I try to download other tracks and I get the error message "could not make request". I guess I could put my number here and maybe someone with way more smarts than me could call and help walk me through it? 

PS. The table has gotten a million compliments and I've had a few friends actually thinking about ordering one. 

Thanks for your help again. Michael


ReplyQuote
(@bruce)
Admin
Joined: 2 years ago
Posts: 213
February 9, 2019 8:54 pm  

@bikertat77 - when you're in settings>advanced - what firmware version does it say you're at?


ReplyQuote
(@bikertat77)
Contributor
Joined: 1 year ago
Posts: 7
February 9, 2019 11:33 pm  

It says 1.10.13


ReplyQuote
(@dithermaster)
Contributor
Joined: 2 years ago
Posts: 53
February 10, 2019 1:08 pm  

What you described is the upload process. It sounds like you're doing it right, although after the spinning black dots you did not mention scrolling up and clicking "Save" which is also required.

The concern is that the .thr file you've download from the internet might not be correct. Try finding one of them using Windows Explorer (or macOS Finder) and right-click on it and choose Open with... and choose Notepad (something like that; don't have a Windows computer nearby to check). When it opens, it should be many lines, and each line should have two numbers separated by a comma. If they don't look like that they they got downloaded incorrectly (in which case delete them and download them again).


ReplyQuote
(@bikertat77)
Contributor
Joined: 1 year ago
Posts: 7
February 10, 2019 3:55 pm  

The spinning black dots just keep spinning until I receive an error message that states "could not make request". I downloaded one track "winter is coming" and it worked. Black dots stopped spinning, clicked on image, hit save and it worked. Tried downloading palm tree, pumpkin, turkey, etc (all one at a time) and starting receiving the error message. I have tried regular google and google chrome. I opened tracks up in text editor and this is what it looks like. The tracks I am downloading is from the community dropbox. I'm assuming that is where the correct tracks are to download. 

This post was modified 10 months ago by bikertat77

ReplyQuote
(@micahr)
Admin
Joined: 2 years ago
Posts: 30
February 11, 2019 9:35 am  

@bikertat77 We're debugging this issue and will post back when we can push a fix. In the mean time, there is a workaround that works for me. When the spinner shows hit save before the error appears. This should still upload the track but the thumbnail may be missing or show up later. Let me know if this does or doesn't work for you.

This post was modified 10 months ago by MicahR

ReplyQuote
(@bikertat77)
Contributor
Joined: 1 year ago
Posts: 7
February 12, 2019 7:00 pm  

I tried that trick and it didn't work. It does save on the tracks, but when I choose the certain download to play, the ball just goes in a circle or runs an erase pattern. Guess I'll have to wait for the debugging to be complete. Just some neat tracks I'd like to share with friends and family and can't. 


ReplyQuote
(@everyoneisanotheryou)
Contributor
Joined: 12 months ago
Posts: 15
February 20, 2019 7:25 pm  

I have a brand new table also. It arrived 2 days ago. I updated the firmware immediately. Track uploading usually fails as others have described (preview image doesn’t render, or is incorrectly showing the last successful preview image, or eventually times out and fails due to a timeout-type error in the browser). What I’ve found usually works is to unplug the table for 10 seconds; plug it in; and then try doing all my uploads in one go after it boots (with drawing paused). Usually, 80-90% of the tracks will upload successfully by doing this. For example, I uploaded 61 official/approved tracks in one go last night, and about 50-55 of them uploaded OK. Several never rendered their preview image.

However, once I see a failure, I must delete the failed track upload and reboot the table and repeat the process for the failed tracks.

This post was modified 10 months ago by EveryoneIsAnotherYou

ReplyQuote
(@bruce)
Admin
Joined: 2 years ago
Posts: 213
February 21, 2019 10:25 am  

Thanks for sharing your work around - I think it may be very helpful for others, while we are trying to improve our download process!


ReplyQuote
(@bikertat77)
Contributor
Joined: 1 year ago
Posts: 7
March 16, 2019 7:45 pm  

have we fixed this issue? I still cannot get any tracks to download from the community or drop box...please help

or can someone who knows how and can walk me through over the phone please? 217-304-6202

This post was modified 9 months ago by bikertat77

ReplyQuote
Share:

We take your privacy seriously and will only use your personal information to provide you with the products and services you request from us. Please see our privacy policy for more details.

  
Working

Please Login or Register